using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<device>{[^^]*})\^(?<topic>{[^^]*})\^(?<payload>.*)$";
string input = @"{""r"":""presenter_id"",""s"":""client0_id"",""id"":""3961825726-request""}^{""requestId"":""3961825726"",""route"":""/basic/handshake/join"",""role"":""request""}^{""playerName"":""Marta""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}