import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([[0-9]+[ \\+\\-\\(\\)[0-9]*]*]*)";
final String string = "This is some text with +1 (234) 222-9898 a phone number in it and a random number 12. Also here is a +44 0800 655 5059 UK number\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}