re = /([[0-9]+[ \+\-\(\)[0-9]*]*]*)/m
str = 'This is some text with +1 (234) 222-9898 a phone number in it and a random number 12. Also here is a +44 0800 655 5059 UK number
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end