const regex = /([[0-9]+[ \+\-\(\)[0-9]*]*]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([[0-9]+[ \\+\\-\\(\\)[0-9]*]*]*)', 'gm')
const str = `This is some text with +1 (234) 222-9898 a phone number in it and a random number 12. Also here is a +44 0800 655 5059 UK number
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}