// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([[0-9]+[ \+\-\(\)[0-9]*]*]*)").unwrap();
let string = "This is some text with +1 (234) 222-9898 a phone number in it and a random number 12. Also here is a +44 0800 655 5059 UK number
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}