import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d *)\\d(?: *\\d *){13,14}\\d(?! *\\d)";
final String string = "Test\n"
+ " \"CC# 123456789012345\",\n"
+ " \"Credit Card 123456 7890 123456\",\n"
+ " \"Text 1234 5678 9012 3456 Text\",\n"
+ " \"Something 123 456 789 012 3456\",\n"
+ " \"Not a card (too long): 12345689123456789123\",\n"
+ " \"Just a value 123\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}