$re = '/(?<!\d *)\d(?: *\d *){13,14}\d(?! *\d)/m';
$str = 'Test
"CC# 123456789012345",
"Credit Card 123456 7890 123456",
"Text 1234 5678 9012 3456 Text",
"Something 123 456 789 012 3456",
"Not a card (too long): 12345689123456789123",
"Just a value 123",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);