import Foundation
let pattern = #"(?<!\d *)\d(?: *\d *){13,14}\d(?! *\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Test
"CC# 123456789012345",
"Credit Card 123456 7890 123456",
"Text 1234 5678 9012 3456 Text",
"Something 123 456 789 012 3456",
"Not a card (too long): 12345689123456789123",
"Just a value 123",
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)