import re
regex = re.compile(r"(?<!\d *)\d(?: *\d *){13,14}\d(?! *\d)", flags=re.MULTILINE)
test_str = ("Test\n"
" \"CC# 123456789012345\",\n"
" \"Credit Card 123456 7890 123456\",\n"
" \"Text 1234 5678 9012 3456 Text\",\n"
" \"Something 123 456 789 012 3456\",\n"
" \"Not a card (too long): 12345689123456789123\",\n"
" \"Just a value 123\",")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")