use strict;
my $str = 'Test
"CC# 123456789012345",
"Credit Card 123456 7890 123456",
"Text 1234 5678 9012 3456 Text",
"Something 123 456 789 012 3456",
"Not a card (too long): 12345689123456789123",
"Just a value 123",';
my $regex = qr/(?<!\d *)\d(?: *\d *){13,14}\d(?! *\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}