using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)";
string input = @"""blahblahblahrgb(123, 214, 255)blahblahrgb(99, 0, 235)aefubaeofbiuaebfaef""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}