$re = '/rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)/m';
$str = '"blahblahblahrgb(123, 214, 255)blahblahrgb(99, 0, 235)aefubaeofbiuaebfaef"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);