package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)`)
var str = `"blahblahblahrgb(123, 214, 255)blahblahrgb(99, 0, 235)aefubaeofbiuaebfaef"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}