re = /rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)/m
str = '"blahblahblahrgb(123, 214, 255)blahblahrgb(99, 0, 235)aefubaeofbiuaebfaef"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end