const regex = /rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rgb\\(\\d{1,3}, \\d{1,3}, \\d{1,3}\\)', 'gm')
const str = `"blahblahblahrgb(123, 214, 255)blahblahrgb(99, 0, 235)aefubaeofbiuaebfaef"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}