using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\d+(?:\.\d+){3}$)0+\.(?:0+\.)*";
string substitution = @"";
string input = @"0.0.4.1
7.51.4.1
0.1.4.1
001
0.1
0.0.0.0";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}