import re
regex = re.compile(r"^(?=\d+(?:\.\d+){3}$)0+\.(?:0+\.)*", flags=re.MULTILINE)
test_str = ("0.0.4.1\n"
"7.51.4.1\n"
"0.1.4.1\n"
"001\n"
"0.1\n"
"0.0.0.0")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)