#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[\r\t\f\v ]*)(\(?[0-9]{3}\)?[-.● ]?[0-9]{3}[-.● ]?[0-9]{4})(?:\s*)"
Local $sString = "email@gmai  (757)-749-0014  " & @CRLF & _
                "(555) 555-5555" & @CRLF & _
                "     (555)555-5555" & @CRLF & _
                "5555555555" & @CRLF & _
                "5555555555" & @CRLF & _
                "(757)-749-0014   " & @CRLF & _
                "   (757)-749-0014" & @CRLF & _
                "" & @CRLF & _
                "" & @CRLF & _
                "" & @CRLF & _
                "INTERIOR DESIGNER RESUME SAMPLE " & @CRLF & _
                "" & @CRLF & _
                "47 Lance Street, Provincetown, MA 02657     (508) 047-1701        juliancrisp@email.com" & @CRLF & _
                "" & @CRLF & _
                "" & @CRLF & _
                "Innovative interior designer with 10 years of experience in project management, space planning, and" & @CRLF & _
                "computer-aided design. Proven ability to transform client ideas into beautiful, functional design" & @CRLF & _
                "solutions. Skilled in color combinations, area improvement, and use of materials and illumination," & @CRLF & _
                "driving innovative and personalized creations." & @CRLF & _
                "" & @CRLF & _
                "Professional Experience" & @CRLF & _
                "INTEGRATED DESIGN SOLUTIONS, PROVINCETOWN, MA" & @CRLF & _
                "Interior Designer, October 2014–present" & @CRLF & _
                ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")