import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(?:[\\r\\t\\f\\v ]*)(\\(?[0-9]{3}\\)?[-.● ]?[0-9]{3}[-.● ]?[0-9]{4})(?:\\s*)";
        final String string = "email@gmai  (757)-749-0014  \n"
	 + "(555) 555-5555\n"
	 + "     (555)555-5555\n"
	 + "5555555555\n"
	 + "5555555555\n"
	 + "(757)-749-0014   \n"
	 + "   (757)-749-0014\n\n\n\n"
	 + "INTERIOR DESIGNER RESUME SAMPLE \n\n"
	 + "47 Lance Street, Provincetown, MA 02657     (508) 047-1701        juliancrisp@email.com\n\n\n"
	 + "Innovative interior designer with 10 years of experience in project management, space planning, and\n"
	 + "computer-aided design. Proven ability to transform client ideas into beautiful, functional design\n"
	 + "solutions. Skilled in color combinations, area improvement, and use of materials and illumination,\n"
	 + "driving innovative and personalized creations.\n\n"
	 + "Professional Experience\n"
	 + "INTEGRATED DESIGN SOLUTIONS, PROVINCETOWN, MA\n"
	 + "Interior Designer, October 2014–present\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}