package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)(?:[\r\t\f\v ]*)(\(?[0-9]{3}\)?[-.● ]?[0-9]{3}[-.● ]?[0-9]{4})(?:\s*)`)
    var str = `email@gmai  (757)-749-0014  
(555) 555-5555
     (555)555-5555
5555555555
5555555555
(757)-749-0014   
   (757)-749-0014
INTERIOR DESIGNER RESUME SAMPLE 
47 Lance Street, Provincetown, MA 02657     (508) 047-1701        juliancrisp@email.com
Innovative interior designer with 10 years of experience in project management, space planning, and
computer-aided design. Proven ability to transform client ideas into beautiful, functional design
solutions. Skilled in color combinations, area improvement, and use of materials and illumination,
driving innovative and personalized creations.
Professional Experience
INTEGRATED DESIGN SOLUTIONS, PROVINCETOWN, MA
Interior Designer, October 2014–present
`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}