#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\.\.?$)(?!.*__.*__)([^\/]{1,10})$"
Local $sString = "foo" & @CRLF & _
"bar/" & @CRLF & _
"12345678901" & @CRLF & _
"foo__bar__" & @CRLF & _
"." & @CRLF & _
".." & @CRLF & _
"foo." & @CRLF & _
"foo.." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")