using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\.\.?$)(?!.*__.*__)([^\/]{1,10})$";
string input = @"foo
bar/
12345678901
foo__bar__
.
..
foo.
foo..
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}