$re = '/^(?!\.\.?$)(?!.*__.*__)([^\/]{1,10})$/m';
$str = 'foo
bar/
12345678901
foo__bar__
.
..
foo.
foo..
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);