re = /^(?!\.\.?$)(?!.*__.*__)([^\/]{1,10})$/m
str = 'foo
bar/
12345678901
foo__bar__
.
..
foo.
foo..
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end