import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\.\\.?$)(?!.*__.*__)([^\\/]{1,10})$";
final String string = "foo\n"
+ "bar/\n"
+ "12345678901\n"
+ "foo__bar__\n"
+ ".\n"
+ "..\n"
+ "foo.\n"
+ "foo..\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}