#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[+-]?\d+(?:\.\d+)?([a-zA-Z])\^2 [+-] \d+(?:\.\d+)?\1 [+-] \d+(?:\.\d+)? = 0|[+-]?\d+(?:\.\d+)?[a-zA-Z] [+-] \d+(?:\.\d+)? = 0)$"
Local $sString = "-3x^2 + 4.8x + 4.0 = 0" & @CRLF & _
"-3x^2 + 4.8y + 4.0 = 0" & @CRLF & _
"5x + 4 = 0" & @CRLF & _
"" & @CRLF & _
"3.0x + 4.9 = 0" & @CRLF & _
"2x + 3 = 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")