import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[+-]?\\d+(?:\\.\\d+)?([a-zA-Z])\\^2 [+-] \\d+(?:\\.\\d+)?\\1 [+-] \\d+(?:\\.\\d+)? = 0|[+-]?\\d+(?:\\.\\d+)?[a-zA-Z] [+-] \\d+(?:\\.\\d+)? = 0)$";
final String string = "-3x^2 + 4.8x + 4.0 = 0\n"
+ "-3x^2 + 4.8y + 4.0 = 0\n"
+ "5x + 4 = 0\n\n"
+ "3.0x + 4.9 = 0\n"
+ "2x + 3 = 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}