$re = '/^(?:[+-]?\d+(?:\.\d+)?([a-zA-Z])\^2 [+-] \d+(?:\.\d+)?\1 [+-] \d+(?:\.\d+)? = 0|[+-]?\d+(?:\.\d+)?[a-zA-Z] [+-] \d+(?:\.\d+)? = 0)$/m';
$str = '-3x^2 + 4.8x + 4.0 = 0
-3x^2 + 4.8y + 4.0 = 0
5x + 4 = 0
3.0x + 4.9 = 0
2x + 3 = 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);