use strict;
my $str = '-3x^2 + 4.8x + 4.0 = 0
-3x^2 + 4.8y + 4.0 = 0
5x + 4 = 0
3.0x + 4.9 = 0
2x + 3 = 0';
my $regex = qr/^(?:[+-]?\d+(?:\.\d+)?([a-zA-Z])\^2 [+-] \d+(?:\.\d+)?\1 [+-] \d+(?:\.\d+)? = 0|[+-]?\d+(?:\.\d+)?[a-zA-Z] [+-] \d+(?:\.\d+)? = 0)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}