import re
regex = re.compile(r"^(?:[+-]?\d+(?:\.\d+)?([a-zA-Z])\^2 [+-] \d+(?:\.\d+)?\1 [+-] \d+(?:\.\d+)? = 0|[+-]?\d+(?:\.\d+)?[a-zA-Z] [+-] \d+(?:\.\d+)? = 0)$", flags=re.MULTILINE)
test_str = ("-3x^2 + 4.8x + 4.0 = 0\n"
"-3x^2 + 4.8y + 4.0 = 0\n"
"5x + 4 = 0\n\n"
"3.0x + 4.9 = 0\n"
"2x + 3 = 0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")