import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+(?:.*\\b(?=[XVI])X?(?:IX|IV|V?I{0,3})\\b(?= +\\S))?) +(.*)";
final String string = "Vladimir Goth\n"
+ "Langraab II Landgraab\n"
+ "Léa Magdalena X Rouault Something\n"
+ "Anna Maria Teodora\n"
+ "Léa Maria Teodora II\n\n"
+ "Langraab XIV Landgraab\n"
+ "Léa Magdalena XIX Rouault Something\n"
+ "Anna Maria Teodora\n"
+ "Léa Maria Teodora XX\n"
+ "Léa Maria Teodora XX NO 20 SUPPORT!!!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}