use strict;
my $str = 'Vladimir Goth
Langraab II Landgraab
Léa Magdalena X Rouault Something
Anna Maria Teodora
Léa Maria Teodora II
Langraab XIV Landgraab
Léa Magdalena XIX Rouault Something
Anna Maria Teodora
Léa Maria Teodora XX
Léa Maria Teodora XX NO 20 SUPPORT!!!
';
my $regex = qr/^(\S+(?:.*\b(?=[XVI])X?(?:IX|IV|V?I{0,3})\b(?= +\S))?) +(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}