const regex = new RegExp('^(\\S+(?:.*\\b(?=[XVI])X?(?:IX|IV|V?I{0,3})\\b(?= +\\S))?) +(.*)', 'gm')
const str = `Vladimir Goth
Langraab II Landgraab
Léa Magdalena X Rouault Something
Anna Maria Teodora
Léa Maria Teodora II
Langraab XIV Landgraab
Léa Magdalena XIX Rouault Something
Anna Maria Teodora
Léa Maria Teodora XX
Léa Maria Teodora XX NO 20 SUPPORT!!!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}