$re = '/^(\S+(?:.*\b(?=[XVI])X?(?:IX|IV|V?I{0,3})\b(?= +\S))?) +(.*)/m';
$str = 'Vladimir Goth
Langraab II Landgraab
Léa Magdalena X Rouault Something
Anna Maria Teodora
Léa Maria Teodora II
Langraab XIV Landgraab
Léa Magdalena XIX Rouault Something
Anna Maria Teodora
Léa Maria Teodora XX
Léa Maria Teodora XX NO 20 SUPPORT!!!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);