import re
regex = re.compile(r"^(\S+(?:.*\b(?=[XVI])X?(?:IX|IV|V?I{0,3})\b(?= +\S))?) +(.*)", flags=re.MULTILINE)
test_str = ("Vladimir Goth\n"
"Langraab II Landgraab\n"
"Léa Magdalena X Rouault Something\n"
"Anna Maria Teodora\n"
"Léa Maria Teodora II\n\n"
"Langraab XIV Landgraab\n"
"Léa Magdalena XIX Rouault Something\n"
"Anna Maria Teodora\n"
"Léa Maria Teodora XX\n"
"Léa Maria Teodora XX NO 20 SUPPORT!!!\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")