package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)#(.+?)\n{2}`)
var str = `# This is a comment,
this is still the same comment.
This, too. These don't matter:## foobar #
code...
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}