re = /#(.+?)\n{2}/
str = '# This is a comment,
this is still the same comment.
This, too. These don\'t matter:## foobar #
code...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end