import re
regex = re.compile(r"#(.+?)\n{2}", flags=re.DOTALL)
test_str = ("# This is a comment,\n"
"this is still the same comment.\n"
" This, too. These don't matter:## foobar #\n\n"
"code...\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")