// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)#(.+?)\n{2}").unwrap();
let string = "# This is a comment,
this is still the same comment.
This, too. These don't matter:## foobar #
code...
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}