import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http|https):\\/\\/)?(www.)?(?!.*(http|https|www.))[a-zA-Z0-9_-]+(\\.[a-zA-Z]+)+(\\/)?.([\\w\\?[a-zA-Z-_%\\/@?]+)*([^\\/\\w\\?[a-zA-Z0-9_-]+=\\w+(&[a-zA-Z0-9_]+=\\w+)*)?$";
final String string = "httpsa://localhost/pwa/deals\n"
+ "https://localhost/pwa/deals\n"
+ "https://localhost/pwa/deals\n"
+ "https://localhost/pwa/deals/api/sdsdsd\n"
+ "fb.com/animesh\n"
+ "sleeptight.com\n"
+ "multitasking.com\n"
+ "a2.com\n"
+ "asdasdasd.com\n"
+ "sdsdc\n"
+ "check abunes.com/\n"
+ "#.in\n"
+ "google@http://asd.com\n"
+ "animes@google.com\n"
+ "test@test.com\n"
+ "--2-\n"
+ "www.com\n"
+ "http://www.computer.com.au/\n"
+ "f4.animesh@google.com\n"
+ "https://animeshsingh.in\n"
+ "http://animeshsingh.in/\n"
+ "someone.ag\n"
+ "someone.br/ads\n"
+ "www.test-my-skills.gov.cz/0999asd-xzc88?0-_/sad%20123/@asdas\n"
+ "Http://www.@test.com\n"
+ "Https://www.@test.com\n"
+ "https://asa .aasd.com\n"
+ "test@asda.test.cas\n"
+ "someone.com\n"
+ "asdasd.com/asdasd/asdasd/asdasd/@asasd\n"
+ "ftp://siva:asdas@sadasd/asd\n"
+ "adc\n"
+ "2@https://www.go.com\n"
+ "www.google.com\n"
+ "https://www.somehow.com/@aasd\n"
+ "https://www.test.facebook.com/@sdas\n"
+ "Https://www.test.com/@masdasd\n"
+ "www.instagram.com/f4animesh\n"
+ "http://www.animeshsingh.in\n"
+ "www.ASD.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}