const regex = /^((http|https):\/\/)?(www.)?(?!.*(http|https|www.))[a-zA-Z0-9_-]+(\.[a-zA-Z]+)+(\/)?.([\w\?[a-zA-Z-_%\/@?]+)*([^\/\w\?[a-zA-Z0-9_-]+=\w+(&[a-zA-Z0-9_]+=\w+)*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((http|https):\\\/\\\/)?(www.)?(?!.*(http|https|www.))[a-zA-Z0-9_-]+(\\.[a-zA-Z]+)+(\\\/)?.([\\w\\?[a-zA-Z-_%\\\/@?]+)*([^\\\/\\w\\?[a-zA-Z0-9_-]+=\\w+(&[a-zA-Z0-9_]+=\\w+)*)?$', 'gm')
const str = `httpsa://localhost/pwa/deals
https://localhost/pwa/deals
https://localhost/pwa/deals
https://localhost/pwa/deals/api/sdsdsd
fb.com/animesh
sleeptight.com
multitasking.com
a2.com
asdasdasd.com
sdsdc
check abunes.com/
#.in
google@http://asd.com
animes@google.com
test@test.com
--2-
www.com
http://www.computer.com.au/
f4.animesh@google.com
https://animeshsingh.in
http://animeshsingh.in/
someone.ag
someone.br/ads
www.test-my-skills.gov.cz/0999asd-xzc88?0-_/sad%20123/@asdas
Http://www.@test.com
Https://www.@test.com
https://asa .aasd.com
test@asda.test.cas
someone.com
asdasd.com/asdasd/asdasd/asdasd/@asasd
ftp://siva:asdas@sadasd/asd
adc
2@https://www.go.com
www.google.com
https://www.somehow.com/@aasd
https://www.test.facebook.com/@sdas
Https://www.test.com/@masdasd
www.instagram.com/f4animesh
http://www.animeshsingh.in
www.ASD.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}