#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\d{3,}@gmail.com)"
Local $sString = "jeff2345@gmail.com" & @CRLF & _
"911@gmail.com" & @CRLF & _
"888clubs@gmail.com" & @CRLF & _
"jeff32@gmail.com " & @CRLF & _
"andygreen024@gmail.com (Real from Imagine Pharma 25June24)" & @CRLF & _
"gs5645902@gmail.com (Real from Imagine Pharma 25June24)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")