package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d{3,}@gmail.com)`)
var str = `jeff2345@gmail.com
911@gmail.com
888clubs@gmail.com
jeff32@gmail.com
andygreen024@gmail.com (Real from Imagine Pharma 25June24)
gs5645902@gmail.com (Real from Imagine Pharma 25June24)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}