import Foundation
let pattern = #"(\d{3,}@gmail.com)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
jeff2345@gmail.com
911@gmail.com
888clubs@gmail.com
jeff32@gmail.com
andygreen024@gmail.com (Real from Imagine Pharma 25June24)
gs5645902@gmail.com (Real from Imagine Pharma 25June24)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)