re = /(\d{3,}@gmail.com)/i
str = 'jeff2345@gmail.com
911@gmail.com
888clubs@gmail.com
jeff32@gmail.com
andygreen024@gmail.com (Real from Imagine Pharma 25June24)
gs5645902@gmail.com (Real from Imagine Pharma 25June24)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end