const regex = /(\d{3,}@gmail.com)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3,}@gmail.com)', 'gi')
const str = `jeff2345@gmail.com
911@gmail.com
888clubs@gmail.com
jeff32@gmail.com
andygreen024@gmail.com (Real from Imagine Pharma 25June24)
gs5645902@gmail.com (Real from Imagine Pharma 25June24)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}