#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\G0"
Local $sString = "000450"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)