const regex = /\G0/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G0', 'g')
const str = `000450`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);