using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G0";
string substitution = @"x";
string input = @"000450";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}