import Foundation
let pattern = #"\G0"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"000450"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)